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Chapter 1 - Enhancements

This chapter presents a high-level description of the following enhancements to the Medisoft 
system. 

In this chapter

Create Patient Statements in Office Hours
You can now create and print patient/guarantor statements in Office Hours. You can use the Quick 
Balance screen in Office Hours in the same way as you use it in Medisoft, with all of the same 
functionality.

Quick Balance screen

New Buttons
New buttons on the Quick Balance screen in Office Hours enable you to view statements and print 
statements with the same functionality as Medisoft. 

Figure 1.  Quick Balance screen

Topic See page
Create Patient Statements in Office Hours 1
Create Statements for Guarantors with no Case 4
Integration with Mobile Devices 4
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Create Statements screen Chapter 1 - Enhancements

Previously, clicking Print displayed the Open Report screen on which you selected a report format. 
Now, clicking Print will display the following screens depending on the situation:

Clicking View Statements will open the BillFlash web page if you are signed up with BillFlash. 

Create Statements screen
The Create Statements screen is now available in Office Hours. Previously, it was only available in 
Medisoft. If the patient/guarantor has charges but no statements, the Create Statements screen 
will appear when you click Print on the Quick Balance screen. Select your Statement Type and click 
Create to create a new statement for the selected patient/guarantor.

Figure 2.  Create Statements screen in Office Hours

Situation Result

If the patient/guarantor has an existing 
statement and no new charges

the Print Statement screen appears for the 
selected patient.

If there are new charges for the patient/
guarantor

the Create Statements screen will appear. 
For more information on this screen, see 
“Create Statements screen” on page 2.

If the patient/guarantor has no balance or 
no cases

you will receive a message saying there 
are no statements to print or there are no 
cases.
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Chapter 1 - Enhancements Print Statement screen

Print Statement screen
When a statement exists for a patient/guarantor, clicking the Print button will display the Print 
Statement screen, just as in Medisoft. The statement method comes from the patient’s record and 
you can select if you want to exclude billed and paid transactions. In addition, select the Update 
Statement Management check box if you want to update the billing status of the statements that 
are being printed.

Figure 3.  Print statement screen in Office Hours

Patient Payment Plan screen
Clicking SHIFT + F5 with the focus in the Chart field on the Quick Balance screen will display the 
Patient Payment Plan screen. You can use this screen as a reference to see when the patient 
should be billed and how much the patient will be billed. Previously, this feature was only available 
from the Quick Balance screen in Medisoft. 

Figure 4.  Patient Payment Plan screen in Office Hours
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Create Statements for Guarantors with no Case Chapter 1 - Enhancements

Create Statements for Guarantors with no Case
You can now create and print statements for guarantors who do not have a case associated with 
their records. Patients with the guarantor assigned will have their accounts printed with the 
guarantor statement.

Integration with Mobile Devices

This feature is available only for Medisoft Network Professional.

You can integrate mobile devices with Medisoft. From the mobile device, you can view 
appointments, enter charges, and update superbill templates for use with the Enter Charges 
feature.

Features of the Mobile Application
Using the mobile application, you can

 • View appointments. Tapping the Schedule icon will show you a list of appointments. You can 
select a day or a week. Tapping an appointment will show you patient detail. including patient 
balances. You can also see multiple providers in a single view. However, you will be able to 
see a Day view only. 

 • Enter charges. Tapping Charges will show you a list of procedures and diagnosis codes. You 
can select a patient and facility, specify if it is a new or existing appointment, specify the 
procedures and diagnosis codes, and submit the charges. You can also enter notes for the 
charges from your mobile device. In Medisoft, these charges will appear in Unprocessed EMR 
Charges. 

The green check mark that appears next to the patient’s name for their appointment on the 
Schedule page after you submit charges is device-specific. That is, it will appear only on the 
device where the charges were submitted, even if you are logged in as the same provider on 
both devices. 

 • Update Superbill Templates. Tapping Setup will allow you to update the template you use for 
entering charges on your mobile device. You can create multiple templates and decide if the 
superbill should be viewed in Portrait or Landscape on your mobile device.

Supported Mobile Devices
You can use the following devices for integration with Medisoft: 

 • iPad (with iOS 5 and above)

 • iPhone 4 (with iOS 5 and above)

 • iPod Touch (with iOS 5 and above)

 • iPad Mini
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Chapter 1 - Enhancements Supported Mobile Devices

Here is a sample of the Scheduling screen from an iPad:

Figure 5.  Scheduling screen on an iPad
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Installation Chapter 1 - Enhancements

Here is a sample of the Scheduling screen on an iPhone.

Figure 6.  Scheduling screen on an iPhone

Installation
All of the files and programs for the mobile service were installed automatically on your desktop 
when you installed Medisoft. These files and programs make it possible for a mobile device to 
access your practice data.

Configuring the Mobile Device
Configure your mobile device before you use it to access information from your practice. Steps for 
configuring your mobile device are found in the Medisoft Installation Guide available on your 
Medisoft DVD. You can also find the Installation guides here

For Customers https://mckwiki.mckesson.com/pps-customer-central/
Medisoft%20Documentation 

For Value-Added Resellers https://mckwiki.mckesson.com/pps-var-central/
Medisoft%20Documentation 
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Chapter 1 - Enhancements New Menu Option

Select the link for Medisoft 18 SP2 documentation.

For each practice that you have, you will need to configure the device separately, since the API key 
and API Code are different for each practice. 

New Menu Option
On the Help menu in Medisoft, there is a new option: Mobile. Selecting this option will show you the 
User API Key and API Code assigned when you installed Medisoft. You will use these to link your 
mobile device to Medisoft after you download and install the mobile application from the Apple App 
Store.

You can check the connection to the server by clicking Check Access.

This screen will also show the Mobile PIN number of the logged in user. For more information on 
the Mobile PIN number, see “Unprocessed Transactions Edit screen” on page 9.

Figure 7.  Mobile screen

New Security Option
You can control which users have access to mobile functionality with a new security permission. 
The default is set to Level 1 so only the system administrator or other Level 1 users can log in from 
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Unprocessed Charges screen Chapter 1 - Enhancements

a mobile device. If you want other users to be able to log in from a mobile device, adjust their 
personal access level or change this security permission to include other levels. 

Figure 8.  Medisoft Security Permissions screen

Unprocessed Charges screen

New Column
A new, unlabeled column (Mobile Notes) on the Unprocessed Charges screen shows if the 
charges that were sent from your mobile device have notes/text attached to them. An icon in the 
column shows if there is a note. This column functions in the same manner as the corresponding 
column in Transaction Entry. Text notes that come from the mobile device will appear in the first 
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Chapter 1 - Enhancements Unprocessed Charges screen

transaction line, with multiple notes part of the same line. You can view these notes from the 
Unprocessed Charged Edit screen.

Figure 9.  Unprocessed Charges screen with Note column

Note: if a note arrives in Unprocessed Charges without a procedure code, you must add one to the 
transaction before you can post it. 

You can access and view notes that come from your mobile device on the Unprocessed 
Transactions Edit screen. The paper icon in the column indicates that a note exists. Click Note to 
view the message.

Figure 10.  Unprocessed Transactions Edit screen



Release Notes
10 Release 18 SP2 March 2013

Security Setup System screen Chapter 1 - Enhancements

Security Setup System screen

New Field
There is a new field on the Security Setup System screen for a PIN number. You can create the 
Mobile PIN number here or create it the first time you log into the practice from the mobile device. 
You’ll use the Mobile PIN number to access the practice from the mobile device if the application 
gets locked on the mobile device.

Figure 11.  Security Setup System screen

Depending on the user’s security level, this field may be disabled. 

The Mobile PIN number must be four digits.
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Chapter 1 - Enhancements New Diagnose Mobile screen

New Diagnose Mobile screen
The Diagnose Mobile screen gives you information on the status of the Mobile Service, as well as 
information for the ports that it is using to communicate. In addition, you can see the version of the 
service. If you are having trouble with your mobile device, use this screen to help identify the issue.

Figure 12.  Diagnose Mobile screen
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New Diagnose Mobile screen Chapter 1 - Enhancements
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Chapter 2 - Resolved Issues

The following issues were resolved with Medisoft Release 18 SP2. 

TD Application Description

22961 Core You can now restore a backup that was password protected. 
Previously, Medisoft would not restore any backup that was 
password protected.

Steps to recreate

1. In Medisoft, on the File menu, point to Backup, and click 
Backup Data.

2. Click OK on the warning screen. The Medisoft Backup 
screen appears.

3. Enter a name and location for the backup.

4. Enter a password.

5. Click OK.

6. Re-enter the password and click OK.

7. Click Start Backup. 

8. Click OK on the message that the backup is complete.

9. Close the Medisoft Backup screen.

10. On the File menu, point to Restore, and click Restore Data.

11. Click OK on the warning message. The Medisoft Restore 
screen appears.

12. Select the backup you just created.

13. Enter the password.

14. Click Start Restore.

15. Verify that the backup is restored without any errors.
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Chapter 2 - Resolved Issues

22976 Core The balance on the Quick Balance screen will now correctly 
include Copays and show the correct balance. Previously, in 
certain situations, such as a partial insurance payment and a 
copay, the balance would be incorrect.

Steps to recreate

1. On the File menu in Medisoft, click Program Options. The 
Program Options screen appears.

2. Select the Billing tab.

3. Select the Add Copay’s to Remainder Statements check 
box.

4. Click Save.

5. Create a new patient and a new case for the patient.

6. Select an insurance carrier on the Policy 1 tab in case 
entry.

7. Select the Assignment of Benefits/Accept Assignment 
check box.

8. Enter an amount in the Copay Amount field.

9. Enter a transaction for the patient and case and pay the 
copay. Note the amount of the charge.

10. Post a payment from the insurance carrier and leave a 
balance for the patient.

11. On the Activities menu, click Quick Balance. The Quick 
Balance screen appears.

12. Select the patient.

13. Verify that the balance is correct. The copay and insurance 
amount paid are subtracted from the charge. 
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Chapter 2 - Resolved Issues

23016 Core You will no longer receive an error when you enter additional 
charges for a patient who has a printed superbill and both Force 
Document Number and User Serialized Superbills selected in 
Program Options. 

Steps to recreate

1. On the File menu in Medisoft, click Program Options. The 
Program Options screen appears. 

2. Click Data Entry. 

3. Select the check boxes for Force Document Number and 
Use Serialized Superbills.

4. Click Save.

5. On the Activities menu, click Appointment Book. The 
Appointment grid appears.

6. Right-click an appointment and click Print Superbills. The 
Open Report screen appears.

7. Click OK.

8. Select either the preview option or the print option.

9. Click Start. The Data Selection Questions screen appears.

10. Make your selections and click OK. 

11. On the Activities menu in Medisoft, click Enter 
Transactions.

12. Select a patient who had a superbill printed.

13. Verify that the superbill number appears in the Superbill 
field.

14. Click the New button to begin entering a new transaction.

15. Verify that you can enter new transactions without any error 
message.

23017 Core Tabbing out of the Transaction Entry grid will no longer cause 
unsaved transaction lines to clear. 

Steps to recreate

1. On the Activities menu, click Enter Transactions.

2. Select a Chart and Case. 

3. In the Charges section, click New.

4. Enter transaction lines. 

5. Press Tab until the focus is no longer on the grid. 

6. Verify that the unsaved transaction lines are still present.
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Chapter 2 - Resolved Issues

23020 Office Hours Office Hours will no longer display a list of all cases for all 
patients after the following steps are taken: click the magnifying 
glass on the Case field of the New or Edit Appointment screen 
and click Cancel on the Case Search Window screen.

Steps to recreate

1. On the Activities menu in Medisoft, click Appointment 
Book. The Appointment grid appears.

2. Highlight an appointment and right-click. 

3. Click Edit. The Edit Appointment screen appears.

4. Click the magnifying glass on the Case field. The Case 
Search Window screen appears.

5. Click Cancel.

6. Click the drop-down arrow on the Case field. 

7. Verify that only cases for the selected patient appear.

23028 Core Medisoft will no longer create two lines on a statement when 
you have a dependent and a guarantor with balances and 
create a statement.

Steps to recreate

1. Create a patient and guarantor for the patient.

2. Create a case and enter transactions for the patient.

3. Press F11. The Quick Balance screen appears.

4. Select the patient. 

5. Follow the steps to print a statement.

6. Verify that there is only one line of information. 

23033 Office Hours Superbills will no longer duplicate with the same number. 
Previously, you could get duplicate superbill numbers if more 
than one workstation was used to print superbills.

Steps to recreate

In Office Hours, have two users attempt to print superbills at the 
same time, using these steps:

1. On the Appointment grid, right-click and select Print 
Superbills.

2. Follow the steps to print the superbills.

3. Verify that the superbill numbers are different. 
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Chapter 2 - Resolved Issues

23134 Core You will no longer receive an error 5177 when removing any 
custom patient or case fields from the Custom Data Field List 
when auditing is enabled for custom patient or custom case 
data. 

Steps to recreate

1. On the File menu, select Program Options. The Program 
Options screen appears.

2. Click the Audit tab. The Audit tab appears.

3. Select Check All. 

4. Click Save.

5. On the Tools menu, click Design Custom Patient Data. 
The Custom Patient Designer appears.

6. On the View menu, click Custom Datafield List. The 
Custom Data Field List appears.

7. Highlight TPLB.

8. Click Delete.

9. Click Yes on the warning message.

10. Click Close.

11. Verify that there is no error. 

23137 Core Quick Balance will now calculate balances correctly for patients 
with multiple cases and different guarantors. Previously, the 
balances would be incorrect.

Steps to recreate

1. In Medisoft, create a patient and create different cases with 
different guarantors.

2. Enter transactions for the patient for each case. 

3. On the Activities menu, click Quick Balance.

4. Select the patient.

5. Select the appropriate case.

6. Verify that the balance is correct. 

7. Select the other case.

8. Verify that the balance for that guarantor is correct.
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